Bug report #18877

Maximum recursion depth exceeded after adding a model or script to the Processing algorithm list (since 2.18.18!)

Added by Oki Sir over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:René-Luc ReLuc
Category:Processing/Core
Affected QGIS version:2.18.19 Regression?:Yes
Operating System:Windows, Linux (Debian Stretch and Ubuntu 17.10) Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26709

Description

When I edit "Providers option" or I add a new model/script to the Processing list, i receive "Maximum recursion depth exceeded while calling a Python object" (see attachment), and so I have to kill the QGis process.

This error appears in QGis version 2.18.18 and 2.18.19 (but not in 2.18.17)

2.18.19.png (60.5 KB) Oki Sir, 2018-04-29 12:06 PM


Related issues

Duplicated by QGIS Application - Bug report #19046: LTR-QGIS crashes after edit a Modell Closed 2018-05-28

History

#1 Updated by Borys Jurgiel over 2 years ago

  • Subject changed from Maximum recursion depth exceeded while calling a Python object to Maximum recursion depth exceeded after adding a model or script to the Processing algorithm list (since 2.18.18!)

It looks very similar to #18807, but that bug was introduced after 2.18.18. Hopefully that fix helped here as well.
Please test on 2.18.20 (to be released May 18, or you can compile 2.18 by yourself).

#2 Updated by Borys Jurgiel over 2 years ago

  • Regression? changed from No to Yes

#3 Updated by René-Luc ReLuc over 2 years ago

  • Priority changed from Normal to High
  • Assignee set to René-Luc ReLuc

After #18807 Enabling/disabling algorithm providers as well as creating/removing preconfigured algorithms causes an infinite loop
It's the other issue introduced by c83261395476b62f6

I will propose a fix.

#5 Updated by Martin Dobias over 2 years ago

#6 Updated by Martin Dobias over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

PR merged few days ago - closing. See 28958199002b12e5fa310490f3da4f03ca104005

Also available in: Atom PDF