Bug report #18634

QGIS3: WMS with HTTPS protocol get requested as HTTP only

Added by Tobias Wendorff over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:3.0.0 Regression?:No
Operating System:Microsoft Windows 7, 64-bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26522

Description

When loading a WMS, which is using HTTPS protocol, HTTP requests are sent out only.
You can see the requests in "Log Messages" or using a proxy server: it's HTTP only (and fails, if the server doesn't redirect to HTTPS).

This bug appears at least in build d48818b492.

History

#1 Updated by Tobias Wendorff over 2 years ago

Addition: of course, you can see the errors in "Log Messages" only. Better use a proxy.

Argh, seems like the admin has setup WMS service the wrong way. GetCapabilities shows:

<OnlineResource xlink:href="http://..."

Override works.

#2 Updated by Tobias Wendorff over 2 years ago

  • Status changed from Open to Closed

Closed, since foreign WMS server is set up the wrong way.

Also available in: Atom PDF