Bug report #18447

"Object has too many attribute" (saving joined layers)

Added by Philipp Lehner over 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Vectors
Affected QGIS version:3.2.1 Regression?:Yes
Operating System:Win 10 Home, 64 bit, Version 1709 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26335

Description

I have joined two layers (point (Geopackage or Spatialite) joined with a table (no geometry)). Each layer has a lot of fields. When I save a new added point I get the message "Object has too many attribute". Saving works.

It works with QGIS 2.18 but not with 3.0

_Ich habe zwei Layer (Punkt (Geopackage oder SpatiaLite) mit einer Tabelle (keine Geometrie) verbunden (Beziehung und Verknüpfung)). Jeder Layer hat viele Felder. Wenn ich einen neu hinzufügten Punkt speichere, erscheint die Meldung "Objekt hat zu viele Attribute, erwarte 47, empfangen 141". Speichern funktioniert.

Es funktioniert mit QGIS 2.18, aber nicht in 3.0_

180315_data-18447.zip - project with database (41.1 KB) Philipp Lehner, 2018-03-15 02:13 PM

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback
  • Priority changed from Normal to High

Can you please attach sample data/project that shows the issue? thanks.

#2 Updated by Philipp Lehner over 2 years ago

Data attached. Thanks!

#3 Updated by Giovanni Manghi over 2 years ago

  • Assignee deleted (Giovanni Manghi)
  • Category changed from Editing to Vectors

Same thing on 3.2?

#4 Updated by Philipp Lehner over 2 years ago

Problem is still existing in 3.2

#5 Updated by Giovanni Manghi over 2 years ago

  • Affected QGIS version changed from 3.0.0 to 3.2.1

#6 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Feedback to Open
  • Subject changed from Too many attributes (saving joined layers) to "Object has too many attribute" (saving joined layers)

#7 Updated by Philipp Lehner about 2 years ago

  • Status changed from Open to Closed

First test with 3.4: Problem seems to be solved, no error message anymore, no problems with saving. Thank you very much!

Also available in: Atom PDF