Bug report #18338

Labels on MSSQL Layers

Added by Josh Knight over 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/MSSQL
Affected QGIS version:3.0.0 Regression?:No
Operating System:Windows 10 Latest Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:26228

Description

When labels are applied to MSSQL linked point database, only a few random points are labelled. When the layer is exported as SHP, then added to layer collection and labelled the same way, all points are labelled.

History

#1 Updated by Josh Knight over 2 years ago

Added info: Only one point is labelled in any view.

#2 Updated by Giovanni Manghi over 2 years ago

  • Category changed from Labelling to Data Provider/MSSQL

#3 Updated by Josh Knight about 2 years ago

  • Status changed from Open to Closed

Discovered the cause of this was the lack of a unique integer column in the table, which I learned about from #12924. I'm not sure if I missed this in the documentation or if it is not mentioned.

#4 Updated by Giovanni Manghi about 2 years ago

  • Resolution set to invalid

Also available in: Atom PDF