Bug report #18272

QGIS 3.0.0 crashed when clicked on zoom to extent in 3D viewer

Added by Andy Whyte over 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:3D
Affected QGIS version:3.0.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:26163

Description

User Feedback

I was opening up the 3d view screen and clicked on zoom to extent.

Report Details

Crash ID: e3c2a9e060da4491cea373e694113d09b7d34d55

Stack Trace

DrvSetLayerPaletteEntries :
DrvSetLayerPaletteEntries :
DrvSetLayerPaletteEntries :
DrvSetLayerPaletteEntries :
RegisterProcTableCallback :
DrvSetLayerPaletteEntries :
Qt3DRender::Render::Renderer::performDraw :
Qt3DRender::Render::Renderer::executeCommandsSubmission :
Qt3DRender::Render::Renderer::submitRenderViews :
Qt3DRender::Render::Renderer::doRender :
Qt3DRender::Render::Renderer::render :
Qt3DRender::Render::NodeManagers::renderTargetManager :
QThread::start :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.0-Girona
QGIS code revision: 001c80b0c3
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.3
Running against GDAL: 2.2.3

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.16299

contour.shp (4.53 MB) Andy Whyte, 2018-02-28 01:58 PM

contour.shx (39.8 KB) Andy Whyte, 2018-02-28 02:02 PM

contour.dbf (104 KB) Andy Whyte, 2018-02-28 02:02 PM


Related issues

Duplicates QGIS Application - Bug report #17315: 3D Viewer: QGIS Crash when activating 3D Map view and 3D ... Feedback 2017-10-22

History

#1 Updated by Giovanni Manghi over 2 years ago

Why this was opened... closed?

#2 Updated by Andy Whyte over 2 years ago

  • Status changed from Closed to Reopened

#3 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Reopened to Open
  • Priority changed from Normal to High

Can you add the data, or it just happen with any data?

#4 Updated by Andy Whyte over 2 years ago

Tried this again and got the same error just from opening a new 3D map view

#5 Updated by Giovanni Manghi over 2 years ago

Andy Whyte wrote:

Tried this again and got the same error just from opening a new 3D map view

is data related or independent?

#6 Updated by Andy Whyte over 2 years ago

This is the data I was using... seems to work intermittently.

#7 Updated by Giovanni Manghi over 2 years ago

Andy Whyte wrote:

This is the data I was using... seems to work intermittently.

just the .shp is not enough (shx, dbf and prj missing). And what about the underlying elevation model?

#8 Updated by Andy Whyte over 2 years ago

I have added the .dbf and .shx, I do not have a .prj.
It does not work without or with the underlying elevation model.

#9 Updated by Giovanni Manghi over 2 years ago

Andy Whyte wrote:

I have added the .dbf and .shx, I do not have a .prj.
It does not work without or with the underlying elevation model.

do you know the CRS of your data?

#10 Updated by Andy Whyte over 2 years ago

Giovanni Manghi wrote:

Andy Whyte wrote:

I have added the .dbf and .shx, I do not have a .prj.
It does not work without or with the underlying elevation model.

do you know the CRS of your data?

Yes it is EPSG: 27700 BNG

#11 Updated by Martin Dobias about 2 years ago

  • Duplicates Bug report #17315: 3D Viewer: QGIS Crash when activating 3D Map view and 3D renderer added

#12 Updated by Martin Dobias about 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #17315 (the same backtrace as reported there)

Also available in: Atom PDF