Bug report #18261

QGIS crashed when clicked on "Plugins" "Manage & Install Plugins"

Added by Sameer Abdool about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:High
Assignee:Borys Jurgiel
Category:Plugin Manager
Affected QGIS version:3.0.0 Regression?:No
Operating System:2012 R2 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes

Description

User Feedback

Clicked on "Plugins" "Loaded/Installed Plugins"

Report Details

Crash ID: 584668a2bc0a803b9f33d1f03034437a538d2dd2

Stack Trace

QString::fill :
QString::indexOf :
QDir::fromNativeSeparators :
QFileInfo::QFileInfo :
QFileInfo::QFileInfo :
QgsMapToolCircle3Points::qt_static_metacall :
QgsMapToolCircle3Points::qt_static_metacall :
PyInit__gui :
PyCFunction_FastCallDict :
PyObject_GenericGetAttr :
PyEval_EvalFrameDefault :
PyErr_Occurred :
PyObject_GenericGetAttr :
PyEval_EvalFrameDefault :
PyErr_Occurred :
PyEval_EvalCode :
PyArena_Free :
PyRun_StringFlags :
instance :
instance :
QgisApp::rotatePointSymbols :
QgsPythonRunner::run :
QgisApp::showPluginManager :
QMetaObject::activate :
QAction::activate :
QMenu::actionGeometry :
QMenu::actionGeometry :
QMenu::mouseReleaseEvent :
QWidget::event :
QMenu::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QApplicationPrivate::sendMouseEvent :
QSizePolicy::QSizePolicy :
QSizePolicy::QSizePolicy :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QGuiApplicationPrivate::processMouseEvent :
QWindowSystemInterface::sendWindowSystemEvents :
QEventDispatcherWin32::processEvents :
DispatchMessageW :
NotifyWinEvent :
QEventDispatcherWin32::processEvents :
qt_plugin_query_metadata :
QEventLoop::exec :
QCoreApplication::exec :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.0-Girona
QGIS code revision: 001c80b0c3
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.3
Running against GDAL: 2.2.3

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.3.9600

History

#1 Updated by Sameer Abdool about 1 year ago

I meant to write "Manage & Install Plugins" from the menu bar.

#2 Updated by Giovanni Manghi about 1 year ago

  • Priority changed from Normal to High
  • Subject changed from QGIS crashed when clicked on "Plugins" "Loaded/Installed Plugins" to QGIS crashed when clicked on "Plugins" "Manage & Install Plugins"

#3 Updated by Borys Jurgiel about 1 year ago

Is your QGIS installed with the normal standalone installer, or OSGeo4W?

#4 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

#5 Updated by Sameer Abdool about 1 year ago

Hi,

When I tried to use the normal installer it failed twice:
1) GDAL202.dll or something similar but GDAL DLL related
2) 2nd time installed it on a server and C++ redistributable package failed.

Then I used OS4Geo4W and the install worked.
Loaded some topographical layers from PostGIS, all good.
I then tried to install some plugins and QGIS crashed.

#6 Updated by Sameer Abdool about 1 year ago

I've just tried GQIS 3.1.0 dev version with GRASS 7.4.0 (nightly)
That works.

QGIS version
3.1.0-Master
QGIS code revision
6bb8a9b610
Compiled against Qt
5.9.2
Running against Qt
5.9.2
Compiled against GDAL/OGR
2.2.3
Running against GDAL/OGR
2.2.3
Compiled against GEOS
3.5.0-CAPI-1.9.0
Running against GEOS
3.5.0-CAPI-1.9.0 r4084
PostgreSQL Client Version
9.2.4
SpatiaLite Version
4.3.0
QWT Version
6.1.3
QScintilla2 Version
2.10.1
PROJ.4 Version
493

#7 Updated by Sebastien Seb about 1 year ago

Seems to be a duplicate of #18220

#8 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to duplicate

#9 Updated by Borys Jurgiel about 1 year ago

Strange...

So it's a fresh install of the OSGeo4W installer? No risk of obsolete stuff in C:\OsGeo4W?

#10 Updated by Borys Jurgiel about 1 year ago

  • Status changed from Closed to Reopened

Giovanni, I'm reopening it and will handle this duplication. It's just odd to communicate with the reporter in a closed ticket ;D and all clues we have here are the reporters' investigations.

#11 Updated by Sameer Abdool about 1 year ago

Just re-downloaded the stand-alone installer for QGIS 3.0.0 x64.
Installed in on my Windows 10 machine and it's now working.
The install filename is QGIS-OSGeo4W-3.0.0-3-Setup-x86_64. What does the "-3" after "3.0.0" means?
Is this a new install package version?

I've used the same setup file on my server and QGIS is still crashing when trying to load plugins.
I'm not using OSGeo4W network installer at all.

#12 Updated by Giovanni Manghi about 1 year ago

  • Resolution deleted (duplicate)

Borys Jurgiel wrote:

Giovanni, I'm reopening it and will handle this duplication. It's just odd to communicate with the reporter in a closed ticket ;D and all clues we have here are the reporters' investigations.

ok!

#13 Updated by Borys Jurgiel about 1 year ago

Sameer Abdool wrote:

Just re-downloaded the stand-alone installer for QGIS 3.0.0 x64.
Installed in on my Windows 10 machine and it's now working.
The install filename is QGIS-OSGeo4W-3.0.0-3-Setup-x86_64. What does the "-3" after "3.0.0" means?
Is this a new install package version?

Yes, it's the third build, so some critical or build-related fixes were applied. AFAICR the postinstall script was fixed, what might solve some problems.

I've used the same setup file on my server and QGIS is still crashing when trying to load plugins.

There is either something in the registry or in the Python paths...

I'm not using OSGeo4W network installer at all.

Ah, so the standalone crashes as well. I misunderstood your note # 5 above.

#14 Updated by Sameer Abdool about 1 year ago

  • Status changed from Reopened to Closed

Resolution:
QGIS 3.0.0 was running from QGIS 2.8 folder for some reason when I updated QGIS using newtwork installer.
I believe that was the problem.

I uninstalled all instances of QGIS and ensured OSGeo4W remnants were discarded except for the one in the C drive.
Re-installed QGIS 3.0.0 using the same stand-alone installer I've downloaded this morning and I can now access the plugins.

Suggestions:
A setup.log file to be produced during install unless already present which I'm not aware of.
Release date for updated installers on QGIS website would be useful.

PS: I would need to investigate the network installer in more details if QGIS was used/updated in a Corporate level combined with batch script(s).

I guess you can put this down to user error and apologies for the inconvenience caused.

Many Thanks,
Sameer

#15 Updated by Borys Jurgiel about 1 year ago

Great thanks for all your investigations! Please don't even call it inconvenience ;)

Also available in: Atom PDF