Bug report #1808

QGIS 1.1 gets the order of items in the layer window out of sequence if dragging a folder too fast.

Added by kumba - about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:11868

Description

When working in QGIS 1.1, I have found that when I add a new layer to the layer stack, and later try to move it down the stack, the ;ayer will cause every folder to expand. This gets annoying.

To solve this, I have in my setup a "tmp" group, and I will place layers to be moved into it. I will then grab and move the whole group to a position next to a targeted folder group, and then I will transfer the layers to their final home. The problem with this is, I have to move the temp folder, or any folder/layer for that matter, slowly. Otherwise, QGIS will actually cause the order of layers to get out of whack.

Think of it this way, if I have a layer stack like this (the + mark indicates a folder group, each with vector layers inside):

+tmp
+md-water
+va-water
+dc-water
+pa-water
+de-water
+wv-water
+md-borders
+va-borders
+dc-borders
+pa-borders
+de-borders
+wv-borders

And if I click/grab the "+tmp" folder, and quickly move it down the list, then in addition to "+tmp" moving down the list, one might find say, "+de-borders" moving up to be in-between "+md-water" and "+va-water". Usually, this happens to multiple folders/layers simultaneously, requiring one to go back and re-order the layering, which in a large layer stack, can be a tedious process.

If you need any kind of debugging output to pin down this problem, let me know.

History

#1 Updated by Giovanni Manghi about 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

This is duplicate of #1637

Also available in: Atom PDF