Bug report #18073

no display of layer loading progress in status bar in actual master

Added by Jan Lippmann almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:Yes
Operating System:Win 7 64bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25969

Description

there is no display of layer loading progress in status bar while project loading. in qgis 2.18 is everything ok (like in the screenshot).

i hope this is no feature ;-)

layer_loading_progressbar.png (13.2 KB) Jan Lippmann, 2018-02-11 04:44 PM

Associated revisions

Revision f10758e1
Added by Mathieu Pellerin - nIRV almost 3 years ago

partial revert of 5dc91b4 to fix regression (fixes #18073)

setMaximumHeight() stays, so hopefully we are still protected
from infinit canvas redraw loop.

History

#1 Updated by Mathieu Pellerin - nIRV almost 3 years ago

  • Regression? changed from No to Yes
  • Assignee set to Mathieu Pellerin - nIRV

#2 Updated by Mathieu Pellerin - nIRV almost 3 years ago

  • Assignee deleted (Mathieu Pellerin - nIRV)

I thought this was a regression from my recent progress bar widget change (from show() hide() to setMaximumWidth()), but after looking into it, it seems to be a different problem altogether.

While in QGIS 2.X you would see the layers being populated in the layers panel as those were being registered, it's not happening now, instead the whole window freezes until the project is fully loaded (and since it's frozen, UI elements aren't updated, such as the progress bar).

Spoke too fast. Reverting the referred change does fix the regression. There must be something Qt does when calling ->show() on hidden widgets which simply setting the maximum width doesn't trigger. Sigh

#3 Updated by Mathieu Pellerin - nIRV almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#4 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF