Bug report #18071

qgis 2.18.16 freezes when opening gpx-file in the "Import other file" tab

Added by Lorenz Wenner over 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:C++ plugins/GPS plugin
Affected QGIS version:2.18.16 Regression?:No
Operating System:debian testing with newest QGIS form unstable Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:25967

Description

Hello there,

i am not sure if i picked the correct category, but here is my bug report.

in GGIS 2.18.16: via menu "Vector | GPS | GPS Tools" in the Tab "Import other file". when I accidently choose a gpx-file here. QGIS freezes and uses 100% CPU. i know that there is the tab "Load GPX file" aside this tab but i think there should be an error message instead of a freeze. i tried starting QGIS via CLI and also via strace but in both cases i did not get any error or log. only a frozen app. I also tried it with "View | Panels | Log Messages Panel" checked, but nothing comes up here once you hit "OK" in the "Import oher file" tab with a gpx file.

Kind Regards
lrnzo

History

#1 Updated by Richard Duivenvoorde over 2 years ago

Can you provide some example data to test/confirm?

#2 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High

#3 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback

#4 Updated by Nelson José Silva over 2 years ago

Working in version 2.18.17

#5 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF