Bug report #1802

problem when using a geographic CRS after changing the central meridian

Added by Giovanni Manghi over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Projection Support
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:11862

Description

Tested with both shapefiles and postgis.

How to reproduce the problem:

*) download this shapefile of the world borders http://thematicmapping.org/downloads/TM_WORLD_BORDERS-0.3.zip

*) add it to your project

*) add a custom CRS with the following definition (for example) "+proj=moll +lon_0=Central Meridian +x_0=False Easting +y_0=False Northing"

*) in the project properties choose the just created CRS and activate OTFR

*) the layer shows correctly

*) now go to the CRS management and change the central meridian "+proj=moll +lon_0=90 +x_0=False Easting +y_0=False Northing"

*) in the project properties change again to wgs84 and back again to the custom CRS, now the shape looks weird.

*) if you zoom in enough the problem disappear

moll.jpg (41.8 KB) Giovanni Manghi, 2009-07-22 06:50 AM

Screenshot.png (13.7 KB) Giovanni Manghi, 2009-07-22 06:52 AM

History

#1 Updated by Magnus Homann over 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

This is a duplicate of #597. As you can see the American continent wraps around, which means the polygons should really by split.

Basically, you can't set up your projections such that geometries must be split.

Also available in: Atom PDF