Bug report #17858

qgis won't start / symbol lookup error: /usr/lib64/libqgis_core.so.2.18.15: undefined symbol: OGR_F_SetFieldNull

Added by Eduardo de juan almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:2.18.15 Regression?:No
Operating System:openSUSE_Leap_42.3 Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:25753

Description

Tras actualizar a la version 2.8.15 QGIS no arranca.

Al intentar arrancar desde una shell aparece el error:
qgis: symbol lookup error: /usr/lib64/libqgis_core.so.2.18.15: undefined symbol: OGR_F_SetFieldNull

He instalado usando yast tras incluir el directorio:
http://download.opensuse.org/repositories/Application:/Geo/openSUSE_Leap_42.3/

un saludo, Eduardo

History

#1 Updated by Eduardo de juan almost 3 years ago

Hi
perhaps it's better if I write in english?

After upgrading to QGIS version 2.8.15 it will not start.
I tried to start from a shell and get the following error:
qgis: symbol lookup error: /usr/lib64/libqgis_core.so.2.18.15: undefined symbol: OGR_F_SetFieldNull

I installed using YAST after including the following repository:
http://download.opensuse.org/repositories/Application:/Geo/openSUSE_Leap_42.3/

greetings

#2 Updated by Jürgen Fischer almost 3 years ago

Looks like you're not using the GDAL QGIS was built with - did you also use the GDAL provided there? Looks like a OpenSUSE packaging problem to me - not sure who maintains the packages there.

#3 Updated by Eduardo de juan almost 3 years ago

I don't know who maintains packages either.
This is what is installed on my system:

[email protected]:~> sudo rpm -aq | grep gdal
libgdal20-2.1.3-3.5.x86_64
python-gdal-2.1.3-3.5.x86_64
gdal-2.1.3-3.5.x86_64

Do you think I should write a ticket for the Suse people ?

BR, Eduardo

#4 Updated by Jürgen Fischer almost 3 years ago

  • Status changed from Open to Feedback

Eduardo de juan wrote:

[email protected]:~> sudo rpm -aq | grep gdal
libgdal20-2.1.3-3.5.x86_64
python-gdal-2.1.3-3.5.x86_64
gdal-2.1.3-3.5.x86_64

Looks like you're using OpenSUSE's stock GDAL instead of the GDAL 2.2.3 from above repository - I guess you should be using that.

#5 Updated by Eduardo de juan almost 3 years ago

I've installed version 2.2.3

python-gdal-2.2.3-60.1.x86_64
libgdal20-2.2.3-60.1.x86_64
gdal-2.2.3-60.1.x86_64

and now QGIS starts fine.

The issue can be closed.

Thanks for your support.

#6 Updated by Jürgen Fischer almost 3 years ago

  • Resolution set to up/downstream
  • Status changed from Feedback to Closed

Also available in: Atom PDF