Bug report #17805

QGIS forms cardinality configuration not correctly applied/saved

Added by Andreas Neumann almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:David Signer
Category:Project Loading/Saving
Affected QGIS version:master Regression?:Yes
Operating System:all Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25701

Description

In the "Layer Properties" --> "Attributes Form" tab there is a list of relations (see screenshot attached).

When one clicks the relation of a n:m relation with an "in-between" table there is the possibility to hide the "in-between" table, because it only contains links to both other tables by setting the cardinality to "Tablename (primary key)".

This used to work before, but now the configuration is not correctly saved and no matter of the setting, the in-between table is always shown.

qgis_cardinality_configuration.png (136 KB) Andreas Neumann, 2018-01-05 04:49 PM

Associated revisions

Revision 8eaecd1c
Added by David Signer almost 3 years ago

relation cardinality bugfix

relation cardinality was handled with it's name as QString instead of it's value as QVector and this leaded to problems in the attribute form.

Fix #17805

History

#2 Updated by Andreas Neumann almost 3 years ago

  • Assignee set to David Signer

#3 Updated by David Signer almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#4 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF