Bug report #17751

Attribute table overwrites ids when selecting in search mode

Added by David Signer over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:David Signer
Category:Attribute table
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:25647

Description

When selecting an attribute in the search mode of the attribute table (Ctrl F) the value is overwritten.

BugSearchAttributeTable.gif (272 KB) David Signer, 2017-12-27 10:59 AM

History

#1 Updated by Saber Razmjooei over 2 years ago

  • Subject changed from Attributetable overwrite of ids when selecting in search mode to Attribute table overwrites ids when selecting in search mode

#2 Updated by David Signer over 2 years ago

For the change to the search mode we could just reset the values on change like we do it in the SingleEditMode. But we have to save them (because of change from single edit mode (when changed some field values)) to search mode.

But actually there is more than that. We got similar problems when switching from SingleEditMode to MultiEditMode:

Or to the SearchMode when in MultiEditMode:

#3 Updated by Denis Rouzaud over 2 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Priority changed from Normal to High

#4 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#5 Updated by David Signer over 1 year ago

Giovanni Manghi wrote:

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

This should be fixed with https://github.com/qgis/QGIS/pull/8299 I don't know why it has been still open. Should I close it manually?

#6 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF