Bug report #17736

Chained filters crash QGIS when switching between ui tabs

Added by Tudor Bărăscu almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:Matthias Kuhn
Category:Relations
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:25632

Description

For a relation with chained filters and custom ui, switching between tabs like in the above gif crashes QGIS Master with the following debug output:

Fatal: ASSERT failure in QList<T>::at: "index out of range", file /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h, line 541

I've attached a demo project, steps to reproduce the bug:

  • Open the form of the pipe
  • Switch to the second tab
  • Switch back to the first tab and the issue is reproduced

The issue disappears when disabling the chain filter option.

chain_relation_bug.gif (228 KB) Tudor Bărăscu, 2017-12-21 01:44 PM

chained_filters_bug.zip - Project_with_bug (24.7 KB) Tudor Bărăscu, 2017-12-21 01:56 PM

Associated revisions

Revision a0d0648d
Added by Denis Rouzaud almost 3 years ago

fix Chained filters crash QGIS when switching between ui tabs

fix #17736

History

#2 Updated by Denis Rouzaud almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#3 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF