Bug report #17692

master 61db97f install breaks on debian stretch

Added by Patrick Dunford over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System:Debian 9 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:25589

Description

A poster to the Qgis-developer list has reported the apt errors for a new installation
The following packages have unmet dependencies:
python-qgis : Depends: python-qgis-common (= 1:2.99.0+git20171211+61db97f+14stretch) but it is not going to be installed
Recommends: liblwgeom-dev but it is not going to be installed
qgis : Depends: qgis-providers (= 1:2.99.0+git20171211+61db97f+14stretch) but it is not going to be installed
Depends: qgis-common (= 1:2.99.0+git20171211+61db97f+14stretch) but it is not going to be installed
qgis-plugin-grass : Depends: qgis-plugin-grass-common (= 1:2.99.0+git20171211+61db97f+14stretch) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

From testing on my computer the apt-upgrade command refuses to install the most recent versions of
python-qgis-common
qgis-common
qgis-plugin-grass-common
qgis-provider-grass
qgis-providers-common
saying they have been held back. They can be installed only if qgis and 2 other packages are uninstalled.

Checking the package repository shows the versions of some of the packages mentioned are
Version: 1:2.99.0+git20171213+ea49c82+14stretch

In other words the repository does not contain the package versions needed for the install.

History

#1 Updated by Jürgen Fischer over 2 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

1:2.99.0+git20171211+61db97f+14stretch is outdated - current builds are 1:2.99.0+git20171219+70d61fd+14stretch.

Also available in: Atom PDF