Bug report #17688

cannot open python console

Added by Denis Rouzaud almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:Denis Rouzaud
Category:PyQGIS Console
Affected QGIS version:2.18.14 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:25585

Description

editing python console settings leads to not being able to open it anymore.

this is due to bad values in colors.

Traceback (most recent call last):
File "", line 2, in
File "/usr/local/Cellar/qgis2/HEAD-2b3744c/QGIS.app/Contents/MacOS/../Resources/python/console/console.py", line 46, in show_console
File "/usr/local/Cellar/qgis2/HEAD-2b3744c/QGIS.app/Contents/MacOS/../Resources/python/console/console.py", line 83, in init
File "/usr/local/Cellar/qgis2/HEAD-2b3744c/QGIS.app/Contents/MacOS/../Resources/python/console/console.py", line 109, in init
File "/usr/local/Cellar/qgis2/HEAD-2b3744c/QGIS.app/Contents/MacOS/../Resources/python/console/console_sci.py", line 86, in init
File "/usr/local/Cellar/qgis2/HEAD-2b3744c/QGIS.app/Contents/MacOS/../Resources/python/console/console_sci.py", line 141, in refreshSettingsShell
TypeError: setCaretForegroundColor(self, QColor): argument 1 has unexpected type 'unicode'

History

#1 Updated by Denis Rouzaud almost 3 years ago

  • Resolution set to wontfix
  • Status changed from In Progress to Closed

This seems to be a mac specific issue, only affected 2.x (not 3.0).

It seems QColor is badly interpreted on mac by QSettings.value.

Also available in: Atom PDF