Bug report #17686

filter does not allow data modification

Added by salvatore fiandaca over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Editing
Affected QGIS version:master Regression?:Yes
Operating System:win 10 64 bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:25583

Description

by applying a filter to a shapefile (right mouse button on layer => filter) it is no longer possible to edit the shapefile, the icon can not be activated.
The problem occurs on 2.18.15 and on the master 010cb1567b - in 2.14.20 it works!!!

N13.jpg - screenshot qgis 2.18.15 (364 KB) salvatore fiandaca, 2017-12-12 09:44 PM

N17.jpg - screenshot master - 010cb1567b (280 KB) salvatore fiandaca, 2017-12-12 09:51 PM


Related issues

Duplicates QGIS Application - Bug report #11189: No shp edit mode when query used? Closed 2014-09-11

History

#1 Updated by salvatore fiandaca over 2 years ago

I add: removing the filter, the problem remains

#2 Updated by Patrick Dunford over 2 years ago

This is probably a duplicate of #17124

#3 Updated by Jürgen Fischer over 2 years ago

#4 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Patrick Dunford wrote:

This is probably a duplicate of #17124

it is.

Also available in: Atom PDF