Bug report #17642

Grass cannot be used in QGIS 2.18.14 LTR on Windows 64bit

Added by Lex Berman almost 3 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GRASS
Affected QGIS version:2.18.14 Regression?:No
Operating System:Windows 7 64bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:25539

Description

The fixes described in previous issue tickets (#16777) had no effect at all.
I tried uninstalling and re-installing the complete OSGEO4W package which also failed.
Then I uninstalled OSGEO4W, rebooted, and re-installed fresh QGIS 2.18.14 stand-alone.

Both cases have the problem of two sets of GRASS showing up in the Processing | Options | Providers settings.
One set is "Grass GIS 7" but the GRASS7 folder cannot be enabled and has no way to set a folder option.
Meanwhile, the second options for "GRASS" can be set and the folder pointed to the grass-7.2.2 folder.

It matters not if a "dummy" msys folder is added to the QGIS 2.18\apps folder.

Basically none of the Grass functions can be used in 2.18.14 in this case.

Thanks for your help in checking it out.

grass_folder_options.jpg (102 KB) Lex Berman, 2017-12-05 10:12 PM

removed_processing_folder.jpg (174 KB) Lex Berman, 2017-12-06 10:46 PM

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Category changed from GRASS to Processing/GRASS
  • Status changed from Open to Feedback

Do you have a "processing" folder inside ~/.qgis2/python/plugins? if yes delete it, restart QGIS and try again (you should not really see the path for "msys" in the GRASS7 options). Thanks!

#2 Updated by Lex Berman almost 3 years ago

Hello Giovanni, thanks much for your reply!
I found a 'processing' folder here:
C:\Program Files\QGIS 2.18\apps\qgis\python\plugins

Moved it to backup disk.
Restarting QGIS did not change anything. Still have 'msys' folders and two sets of QGIS functions under OPTIONS.
Also tried de-activating, restarting, activating, restarting, but get the same situation. Unable to run any GRASS tools.

#3 Updated by Lex Berman almost 3 years ago

  • Assignee set to Lex Berman
  • Status changed from Feedback to Open

Grass cannot be run in QGIS 2.18.
Recently I tried the same on Mac OSX running 2.18.13, which fialed due to "wrong value parameter GRASS FOLDER" "Specified path does not exist: /Applications/GRASS-6.4.app/Contents/MacOS"

I removed the entire installation of QGIS and started from a fresh install of QGIS 2.18.15-1.

Same error.

There are TWO GRASS sections under Processing > Options > Providers (1) FRASS GIS 7 Commands (2) GRASS commands. It seems like the latter is looking for Grass 6.4, however the ACTIVATE box is unchecked. And this is preventing me from clicking on the OK button in order to run other scripts (such as R).

Basically, I cannot use Grass as expected in either Windows 64bit or Mac OSX dmg versions, which also interferes with enabling R scripts.

#4 Updated by Andrea Tapia about 2 years ago

Hi, I had the same issue so what i did to solve it was to just erase the path of the GRASS7, because it was not using it anyway... so, I erase the path and clicked ok. Problem solved.

Cheers,

#5 Updated by Giovanni Manghi about 2 years ago

  • Assignee deleted (Lex Berman)
  • Status changed from Open to Closed
  • Resolution set to not reproducable

Did recently some fresh installations of 2.18.24 on Windows and Processing/GRASS is just fine.

Also available in: Atom PDF