Bug report #17623

If the current feature ($geometry) falls outside the canvas's visibility area, the geometry generated with the geometry generator symbology is no longer visible

Added by salvatore fiandaca almost 3 years ago. Updated over 2 years ago.

Status:Open
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:25520

Description

sorry if I use google translator.

adding a geometry-generator layer to a layer (example: buffer ($ geometry, 100)), if the current feature ($ geometry) falls outside the canvas's visibility area, the buffer is no longer visible.

bug.7z - data and project (3.48 KB) salvatore fiandaca, 2017-12-04 06:06 PM

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Status changed from Open to Feedback

Can you attach a screenshot or a sample project with data to prove/show the issue? thanks!

#2 Updated by salvatore fiandaca almost 3 years ago

salvatore fiandaca wrote:

sorry if I use google translator.

adding a geometry-generator layer to a layer (example: buffer ($ geometry, 100)), if the current feature ($ geometry) falls outside the canvas's visibility area, the buffer is no longer visible.

I attach data and project 2.18.14

#3 Updated by Giovanni Manghi almost 3 years ago

I attach data and project 2.18.14

does it work as expected on 2.18.14?

#4 Updated by salvatore fiandaca almost 3 years ago

Giovanni Manghi wrote:

I attach data and project 2.18.14

does it work as expected on 2.18.14?

no,
same problem in 2.18.14 and master

#5 Updated by Giovanni Manghi over 2 years ago

  • Subject changed from geometry-generator theme 2.18.14 and master to If the current feature ($geometry) falls outside the canvas's visibility area, the geometry generated with the geometry generator symbology is no longer visible
  • Status changed from Feedback to Open

#6 Updated by salvatore fiandaca over 2 years ago

I did a test with QGIS 3.0 Girona: the problem is still present.
I used the data and project attached.

#7 Updated by Giovanni Manghi over 2 years ago

  • Operating System deleted (win 10 64b)
  • Affected QGIS version changed from master to 3.0.0

Also available in: Atom PDF