Bug report #17612

Values in form view appear as NULL

Added by Saber Razmjooei almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Attribute table
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:25509

Description

but are shown correctly in the table view

attribute_form.PNG - Because no particular feature is set, form is full of NULL values (24.7 KB) Harrissou Santanna, 2017-12-04 06:24 PM

History

#1 Updated by Saber Razmjooei almost 3 years ago

  • Status changed from Open to Closed

Magically it got resolved!

#2 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to not reproducable

#3 Updated by Harrissou Santanna almost 3 years ago

Magically it got resolved!

Are you sure, Saber :) ? Isn't it because you just switch to the form view after opening the attribute table (without "selecting" any feature)? I think it has always been this way.

I mean when you open the attribute table in view form, attributes are ALL shown 'NULL' given that no particular feature is "displayed". This is really confusing (took me time to figure out this dialog behavior). I think that attributes of the first feature in the list should be displayed instead of those empty fields.
I let Giovanni decide if it should be reopened.

Also available in: Atom PDF