Bug report #17590

No Python support detected thus no settings available + No processing algorithms under Vector and Raster menu.

Added by Ben Hur Pintor over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:Xubuntu 16.04 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:25487

Description

Hi all! I built QGIS master (d7485a4) using the instructions from (a) https://github.com/qgis/QGIS/blob/master/INSTALL supplemented by (b) https://www.lutraconsulting.co.uk/blog/2017/08/06/qgis3d-build/ because I wanted to try the new 3D features. My machine runs on Xubuntu 16.04. The build works fine. However, when I run QGIS, I notice that:

1.) Plugins are unavailable. The Settings tab of "Manage and Install Plugins" says "No Python support detected thus no settings available." Is this normal? I've only tried building QGIS recently so I don't know if it is.

2.) There seems to be no processing algorithms under the Vector and Raster menus aside from Raster calculator and Align rasters (+ the core plugins that I activate).

Did I do something wrong with my build or is this normal?

Thank you in advance! Cheers!

Compiled against Qt 5.9.1
Compiled against GDAL/OGR 2.2.2
Compiled against GEOS 3.5.1-CAPI-1.9.1
PostgreSQL Client Version 9.5.10
QWT Version 6.1.3
QScintilla2 Version 2.10.1

Running against Qt 5.9.1
Running against GDAL/OGR 2.2.2
Running against GEOS 3.5.1-CAPI-1.9.1 r4246
SpatiaLite Version 4.3.0a
PROJ.4 Version 492

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Hi,
question are better asked in the users or developers mailing lists, thanks!

Also available in: Atom PDF