Bug report #17570

Crash when using 3D model for point layer

Added by Nadiia Gorash over 2 years ago. Updated about 1 year ago.

Status:Closed
Priority:High
Assignee:Martin Dobias
Category:3D
Affected QGIS version:master Regression?:No
Operating System:windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:25467

Description

User Feedback

Tried to use 3D Map . WMS layer, DEM and point shp file have been prior added to the project.
The 3D model was selected for point dataset.

QGIS crashed when I opened new 3D map window.

Report Details

Crash ID: 7dd7cadc2bb2115f5b1de1a0f456e708127226d7

Stack Trace

Qt3DRender::QUrlHelper::urlToLocalFileOrQrc :
Qt3DCore::QAbstractAspectPrivate::createBackendNode :
Qt3DCore::QAbstractAspectPrivate::sceneNodeAdded :
Qt3DCore::QChangeArbiter::distributeQueueChanges :
Qt3DCore::QChangeArbiter::syncChanges :
Qt3DCore::QAspectManager::exec :
Qt3DCore::QAspectManager::unregisterAspect :
QThread::start :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 2.99.0-Master
QGIS code revision: 82644fb37f
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.2
Running against GDAL: 2.2.2

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.1.7601

3d test.qgs - project file (25 KB) Nadiia Gorash, 2017-11-29 09:47 PM

3dmapissue.zip (1.07 MB) Nadiia Gorash, 2017-11-29 09:49 PM

inveraray+castle.skp - 3d Model I tried to use (3.54 MB) Nadiia Gorash, 2017-11-29 10:02 PM

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High

#2 Updated by Nadiia Gorash over 2 years ago

Hi, sorry I can't attached the data used as it exceeds allowed limit, so uploaded it here https://we.tl/LiGJ5LKbZH

#3 Updated by Martin Dobias over 2 years ago

  • Status changed from Open to Feedback

Thanks for the data, but so far I was unable to replicate the crash. You mention that you have used a 3D model for the points layer - I have not seen any such file in the attached ZIP file. Would it be possible to attach it? From the stack trace I think the crash could have been related to the 3D model file.

It would be also very helpful if you attach your QGIS project file with all the data loaded and configured (saved before you open 3D view).

#4 Updated by Nadiia Gorash over 2 years ago

Hi Martin,

i've attached QGIS project file and a 3d model i tried to use, i've also made a windows prs recording to illustrate what i'm doing.

This time the crash happened when i tried to select a model after 3DMap window was open.

#5 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Feedback to Open

#6 Updated by Martin Dobias over 2 years ago

This looks like upstream bug in Qt. I have reported it here: https://bugreports.qt.io/browse/QTBUG-64916

I think right now it is not safe to use "3D Model" option with more than just a few points in the layer.

Also please note that your 3D model (.skp file) is not supported by Qt 3D from what I can tell - you will need to export it to one of the formats supported by assimp library - see http://assimp.org/main_features_formats.html - e.g. Collada (.dae) or Wavefront Object (.obj) are known to work fine.

#7 Updated by Martin Dobias over 2 years ago

  • Subject changed from 3D Map crash to Crash when using 3D model for point layer

#8 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#9 Updated by Jürgen Fischer about 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to no timely feedback

Bulk closing 82 tickets in feedback state for more than 90 days affecting an old version. Feel free to reopen if it still applies to a current version and you have more information that clarify the issue.

Also available in: Atom PDF