Bug report #17562

WMS legend broken for percent-encoded LegendURL's

Added by Richard Duivenvoorde almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:Yes
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25459

Description

Some WMS services, eg:

http://gisservices.noord-holland.nl/ags/services/pnh_dataservice_alg/MapServer/WMSServer?request=GetCapabilities&service=WMS

have their (valid) LegendURL's percentage-encoded in the capabilities, eg:

http://gisservices.noord-holland.nl/ags/services/pnh_dataservice_alg/MapServer/WmsServer?request=GetLegendGraphic%26version=1.3.0%26format=image/png%26layer=Bouwen op slappe grond - Damwand complexiteit

While this was working in 2.18/qt4, this returns a 'flawed image' in 2.99 because QGIS adds a second &FORMAT=image/png to the url, while the server can apparently only handle one.

I'll add a Pull Request to fix this.

Associated revisions

Revision f6ffb00c
Added by Richard Duivenvoorde almost 3 years ago

fix #17562 broken legend uris

History

#3 Updated by Richard Duivenvoorde almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#4 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF