Bug report #17529

QGIS 3D view - Flickering and blank white screen with rotating and titling viewport

Added by Jeremy Palmer about 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:Martin Dobias
Category:3D
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:25426

Description

See video showing issues on MacOSX running b288a5f: https://youtu.be/OwTXqmJJ5IY

Note the white gaps in the 3D terrain on the tile edges. Also the input layers are WMTS raster layer and a tiled (single band VRT) DEM layer.

History

#2 Updated by Martin Dobias about 3 years ago

The gaps between tiles can be hidden by increasing the "skirt height" option in terrain configuration... the skirts are additional vertical walls on the edges of terrain tiles (a technique used in other terrain engines as well).

The flickering you get is something I have not seen before - it looks like all terrain tiles get culled. Could you please check if the flickering goes away if you use a smaller area, e.g. just one tile with DEM instead of using a whole bunch of them through VRT?

#3 Updated by Jeremy Palmer about 3 years ago

The gaps between tiles can be hidden by increasing the "skirt height" option in terrain configuration... the skirts are additional vertical walls on the edges of terrain tiles (a technique used in other terrain engines as well).

Thanks changing this to 200 fixed the issue.

The flickering you get is something I have not seen before - it looks like all terrain tiles get culled. Could you please check if the flickering goes away if you use a smaller area, e.g. just one tile with DEM instead of using a whole bunch of them through VRT?

Now I can't replicate the issue! I need to determine the exact steps to get this flickering happening again. Maybe it's only after some time in the application.

#4 Updated by Giovanni Manghi about 3 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

Reopen if/when necessary.

Also available in: Atom PDF