Bug report #1739

Opening QGS project with WMS layer while offline crashes QGIS 1.0.2

Added by Mike Taves over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11799

Description

I have recreated this bug on QGIS 1.0.2 Windows from both standalone and OSGeo4W.
1. While online, create and save a QGS project that has at least 1 WMS layer (which can be saved with WMS on/off -- it doesn't matter)
1. Close QGIS, and disconnect from all internet connections
1. Start QGIS, and open previous project file (from recently save project list)
1. Crash!

I have also tested this with 1.1.0 and 1.2.0 (both unstable via OSGeo4W), and it appears to work as expected while offline (no crash). The external WMS does not render, since the computer is offline.

Thanks for the fix in unstable versions! I searched for this ticket, but did not find it. The purpose of this ticket is that I'd like this fix backported to the stable 1.0.3 release.

History

#1 Updated by Giovanni Manghi over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Hi,

I don't think that this fix will be backported to 1.0.x, so I'll close this ticket. Feel free to reopen it if you feels so.

Also available in: Atom PDF