Bug report #17242

QGIS 3 is storing cache in windows roaming profile?

Added by Arnaud Poncet-Montanges over 2 years ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:Arnaud Poncet-Montanges
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System:Windows 7 x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25140

Description

I've noticed some problems due to my windows roaming profile size recently.

It's not only QGIS 3 fault but I would avoid as much as possible to store too much data there.

Roaming.png - Roaming (68.6 KB) Arnaud Poncet-Montanges, 2017-10-04 08:30 AM

cache_roaming.png (16.2 KB) Arnaud Poncet-Montanges, 2019-03-13 10:47 AM

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from High to Normal

#2 Updated by Andreas Neumann over 2 years ago

I agree that this a big problem for Windows users with roaming profiles (such as most gov organizations, companies, etc.)

Storing many MB of cache content in the roaming profile slows logging into Windows a lot and ultimately such users will get complaints from their IT department.

#3 Updated by Regis Haubourg over 2 years ago

On my side, I usually set a low cache size value in the settings to avoid this but that's true that cache should be in the local profile only.

#4 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

Please check if this issue is still valid on QGIS 3.4.5 or 3.6.

#5 Updated by Arnaud Poncet-Montanges about 1 year ago

Seems to be fine.

C:\Users\user\AppData\Roaming\QGIS\QGIS3\profiles\default\cache

10000 is 10000 Mo?

#6 Updated by Arnaud Poncet-Montanges about 1 year ago

  • Assignee set to Arnaud Poncet-Montanges

This can be closed

#7 Updated by Giovanni Manghi about 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF