Bug report #17240

When a node on the end of a path is selected and dragged, the whole line moves instead of just that node

Added by Patrick Dunford about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System:Xubuntu 17.10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:25138

Description

This is not very intuitive with the new editing system. If my line has a node on the end of it, and I put the mouse over that node and click it, I should be able to drag just that node to a new position (as was the case with the previous digitising/editing system). Instead, the whole line moves (like the moving tool does).

(see also discussion in #16836)


Related issues

Related to QGIS Application - Bug report #16836: A lot harder now to insert new nodes into lines and resha... Closed 2017-07-10

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback

Same comment as #16836-8

I can understand your point but it could be very well a decision taken on purpose by who re-designed the tools. This should be discussed in the community and then eventually consider it a bug.

#2 Updated by Andreas Neumann about 3 years ago

I agree with Patrick. Selecting a single vertex, only that vertex should be moved, not the whole segment or even the whole feature.

#3 Updated by Patrick Dunford about 3 years ago

Just started a thread on the developers list

#4 Updated by Harrissou Santanna about 3 years ago

I can't reproduce using 58f64bb4 on Win 10

#5 Updated by Giovanni Manghi about 3 years ago

Also can't confirm.

#6 Updated by Patrick Dunford about 3 years ago

Not sure about this one at the moment. It was definitely happening yesterday when I was trying to edit some data, but I haven't nailed it down today.

#7 Updated by Jürgen Fischer about 3 years ago

  • Related to Bug report #16836: A lot harder now to insert new nodes into lines and reshape lines in 7d67b02 than in previous Master 313ec55 added

#8 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Please reopen if you have a clear way to replicate the problem. Thanks!

Also available in: Atom PDF