Bug report #17236

Unable to edit layer while filter is in effect

Added by Patrick Dunford over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Editing
Affected QGIS version:master Regression?:No
Operating System:Xubuntu 17.10, Debian 9.1 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:25135

Description

If a layer has a filter applied, that layer cannot be put into edit mode.

see also #17124


Related issues

Duplicates QGIS Application - Bug report #2951: Layers become non-editable Closed

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Open to Feedback

Why opening another ticket, wasn't #17124 enough?

#2 Updated by Patrick Dunford over 3 years ago

Doesn't fit the test case shown in that ticket (which I obviously have read)

#3 Updated by Jürgen Fischer over 3 years ago

  • Resolution set to duplicate

Duplicate of #2951

#4 Updated by Jürgen Fischer over 3 years ago

#5 Updated by Jürgen Fischer over 3 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF