Bug report #1712

Improper qgis shutdown corrupts GRASS vector layer

Added by mir123 - over 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:Lorenzo Masini
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11772

Description

While editing a GRASS vector layer stored remotely on the network, I closed qgis without first going back to not editing the layer. It gave me a message along the lines of "expect a crash".

Upon restart my layer was corrupted and qgis wouldn't open it. It turns out the topology file was missing, requiring a v.build from the GRASS command line to fix layer.

Qgis should check for open layers in the GRASS plugin before closing!

History

#1 Updated by Lorenzo Masini about 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in 1e53f585 (SVN r11186).

Also available in: Atom PDF