Bug report #17029

Labels settings inside style dock does not update accordingly to selected layer

Added by Dominique Lyszczarz about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24928

Description

Steps to reproduce the issue:
- start a new project and open 2 differents layers
- Enable layer styling panel
- Enable and setup labels for each layers
- Now changing the selected layer in the TOC does not update labels settings in the panel

Associated revisions

Revision 471204dd
Added by Mathieu Pellerin - nIRV almost 3 years ago

[style dock] fix wrong label settings when switching layers

(fixes #17029)

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback
  • Category changed from GUI to Labelling

Does this affect only master or also 2.18.11?

#2 Updated by Dominique Lyszczarz about 3 years ago

Only in master

#3 Updated by Giovanni Manghi about 3 years ago

  • Subject changed from Labels settings inside style dock does not update accordingly to selected leyer to Labels settings inside style dock does not update accordingly to selected layer
  • Status changed from Feedback to Open
  • Regression? changed from No to Yes
  • Priority changed from Normal to High

#4 Updated by Regis Haubourg about 3 years ago

Confirmed here several times working on new auxiliary data storage. This leads to situations where we erase settings when using dynamic style dock.

#5 Updated by Mathieu Pellerin - nIRV almost 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in commit 471204dd4de2225979a1846209bfcb39700aeeba.

Also available in: Atom PDF