Bug report #17025

build error on Linux

Added by Sergey Zhemoitel over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.18.11 Regression?:No
Operating System:ROSA Linux Fresh R8.1 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24924

Description

# make
...
[  8%] Building CXX object src/core/CMakeFiles/qgis_core.dir/qgstracer.cpp.o
/home/admin/rpmbuild/BUILD/qgis-2.18.11/src/core/qgstracer.cpp: In the member function «bool QgsTracer::initGraph()»:
/home/admin/rpmbuild/BUILD/qgis-2.18.11/src/core/qgstracer.cpp:533:91: Error: There is no declaration of «GEOSNode_r» in this scope
     GEOSGeometry* allNoded = GEOSNode_r( QgsGeometry::getGEOSHandler(), allGeom->asGeos() );
                                                                                           ^
make[2]: *** [src/core/CMakeFiles/qgis_core.dir/build.make:5619: src/core/CMakeFiles/qgis_core.dir/qgstracer.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1166: src/core/CMakeFiles/qgis_core.dir/all] Error 2
make: *** [Makefile:161: all] Error 2

cat /etc/release 
ROSA Desktop Fresh R8.1 release 2014.1 for x86_64

uname -a
Linux nb 4.9.34-nrj-desktop-1rosa-x86_64 #1 SMP PREEMPT Sun Jun 25 17:10:14 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

rpm -qa | grep gcc
gccxml-3.20.0-6-rosa2014.1.x86_64
lib64gcc1-4.9.4_2017.01-5-rosa2014.1.x86_64
libgcc1-4.9.4_2017.01-5-rosa2014.1.x86_64
gcc-cpp-4.9.4_2017.01-5-rosa2014.1.x86_64
gcc-4.9.4_2017.01-5-rosa2014.1.x86_64
gcc-c++-4.9.4_2017.01-5-rosa2014.1.x86_64
gcc-java-4.9.4_2017.01-5-rosa2014.1.x86_64
gcc-go-4.9.4_2017.01-5-rosa2014.1.x86_64
gcc-gfortran-4.9.4_2017.01-5-rosa2014.1.x86_64

rpm -qa | grep cmake
cmake-3.5.2-1-rosa2014.1.x86_64
extra-cmake-modules-5.24.0-1-rosa2014.1.noarch

History

#1 Updated by Jürgen Fischer over 3 years ago

  • Subject changed from Crash build on Linux to build error on Linux
  • Description updated (diff)

#2 Updated by Jürgen Fischer over 3 years ago

  • Description updated (diff)

#3 Updated by Jürgen Fischer over 3 years ago

  • Description updated (diff)

#4 Updated by Jürgen Fischer over 3 years ago

  • Status changed from Open to Feedback

Are you using GEOS >=3.4?

#5 Updated by Sergey Zhemoitel over 3 years ago

Jürgen Fischer wrote:

Are you using GEOS >=3.4?

rpm -qa | grep geos
lib64geos3.3.5-3.3.5-3-rosa2014.1.x86_64
lib64geos_c1-3.3.5-3-rosa2014.1.x86_64
lib64geos-devel-3.3.5-3-rosa2014.1.x86_64

#6 Updated by Jürgen Fischer over 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

Update GEOS. QGIS requires GEOS >=3.4.

#7 Updated by Sergey Zhemoitel over 3 years ago

Thank you

Also available in: Atom PDF