Bug report #1701

copy and paste of objects should take care of CRS

Added by Marco Lechner over 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Projection Support
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11761

Description

By copying objects from one vectorlayer to another should take care of different KBS of the layers if they vary (e.g. if On-The-Fly-Projection is used).
Right now the copy/patse doesn't work as expected, not taking care of that, because copy/paste is possible, but produces wrong results in those cases.

Associated revisions

Revision 2779129e
Added by Magnus Homann about 10 years ago

Added OTFP to the clipboard contents (if OTFP is on). Fixes #1701

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision e4f05aa8
Added by Magnus Homann about 10 years ago

Added OTFP to the clipboard contents (if OTFP is on). Fixes #1701

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Giovanni Manghi about 10 years ago

Still true on qgis 1.2 from trunk.

Pushing the milestone.

#2 Updated by Magnus Homann about 10 years ago

What is 'KBS'???

#3 Updated by Giovanni Manghi about 10 years ago

CRS, I guess...

#4 Updated by Giovanni Manghi about 10 years ago

For what I see now on the user manual (tip 21 on page 58 of the qgis 1.1 manual) it seems that when pasting a feature from a layer with a different projection, qgis should reproject it (but with an advice of possibly have the geometry of the pasted layer changed), so the bug should be confirmed.

Please check it and correct me if I'm wrong, because it seems strange to me that a documented feature is not working the right way.

From the manual

CONGRUENCY OF PASTED FEATURES
If your source and destination layers use the same projection, then the pasted features will have geometry identical to the source layer. However if the destination layer is a different projection then QGIS cannot guarantee the geometry is identical. This is simply because there are small rounding-off errors involved when converting between projections.

#5 Updated by Magnus Homann about 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in e4f05aa8 (SVN r11410).

Also available in: Atom PDF