Bug report #16940

getting can not import QtWebKit error message while installing sextante plugin in QGIS 1.8.0 -Lisboa

Added by Gouri Kadam almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:Borys Jurgiel
Category:Plugin Manager
Affected QGIS version:1.8.0 Regression?:No
Operating System:Linux 64 bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24839

Description

Dear Admin,

I am getting above mentioned error though PyQt4 is installed already.Error log is
Couldn't load plugin 'sextante' from ['/usr/share/qgis/python', '/home/gouri/.qgis//python', '/home/gouri/.qgis//python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib64/python2.6/site-packages/SWMM5-5.1.0.102-py2.6-linux-x86_64.egg', '/usr/lib64/python26.zip', '/usr/lib64/python2.6', '/usr/lib64/python2.6/plat-linux2', '/usr/lib64/python2.6/lib-tk', '/usr/lib64/python2.6/lib-old', '/usr/lib64/python2.6/lib-dynload', '/usr/lib64/python2.6/site-packages', '/usr/lib64/python2.6/site-packages/PIL', '/usr/lib64/python2.6/site-packages/gst-0.10', '/usr/lib64/python2.6/site-packages/gtk-2.0', '/usr/lib64/python2.6/site-packages/webkit-1.0', '/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode', '/usr/lib/python2.6/site-packages', '/usr/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg-info', '/usr/share/qgis/python/plugins/fTools/tools']

error_sextante - detailed error file attached herewith (3.45 KB) Gouri Kadam, 2017-07-28 11:22 AM

History

#1 Updated by Borys Jurgiel almost 3 years ago

It seems either your PyQt4 installation doesn't provide the QtWebKit module at all, or it does, but under different path that the default PyQt4.QtWebKit. You didn't tell much about your operating system, but please ensure you don't need to install an additional package (like python-qt4-qtwebkit or so) in your package manager.

Please note QGIS 1.8 is very outdated now and not supported for years. The same with Sextante.

#2 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Agree with Borys, 1.8 is completely outdated and unsupported. Please install the latest LTR (2.14.17) or 2.18.11. No need to install "sextante", along the years is became "Processing" and is now part of QGIS out of the box.

#3 Updated by Gouri Kadam almost 3 years ago

What is the latest version of QGIS for linux system. I have installed 1.8 which i found latest for linux OS. same error occurs while installing TauDEM plugin

#4 Updated by Giovanni Manghi almost 3 years ago

Gouri Kadam wrote:

What is the latest version of QGIS for linux system. I have installed 1.8 which i found latest for linux OS. same error occurs while installing TauDEM plugin

http://www.qgis.org/en/site/forusers/download.html

#5 Updated by Gouri Kadam almost 3 years ago

This link is redirecting to QGIS 1.8 for Red Hat Linux OS which I have installed already.

#6 Updated by Giovanni Manghi almost 3 years ago

Gouri Kadam wrote:

This link is redirecting to QGIS 1.8 for Red Hat Linux OS which I have installed already.

try this

https://copr.fedorainfracloud.org/coprs/neteler/QGIS-2.18-Las-Palmas/

worked for me with no issues on CentOS.

#7 Updated by Gouri Kadam almost 3 years ago

ok Thanks. Will try installing this.

Also available in: Atom PDF