Bug report #16918

problem when rotate composite symbols

Added by Luca Lanteri about 3 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:No Copied to github as #:24817

Description

If I have a symbol composed by 2 simple symbols and one of them is rotated, when I apply a rotation to the composed symbol this is plotted wrong in legend and TOC (the two part are no more reciprocally rotated of 90°).

eg:
- I made simbol "giaciture" composed by two lines reciprocally rotated of 90°
- I apply a rotation to "giaciture" driven by a field 'immersione'
- Symbol are correct in map composer but not in legend and TOC.

try with attached example.

Tested on QGIS 2.18.10 on linux MINT 18.

giacitura.gpkg - example dataset (63 KB) Luca Lanteri, 2017-07-22 06:17 PM

giacitura.xml Magnifier - symbology (2.25 KB) Luca Lanteri, 2017-07-22 06:18 PM

Screenshot_20170724_123832.png (215 KB) Giovanni Manghi, 2017-07-24 01:39 PM

screenshot_symbology.png (319 KB) Alberto Grava, 2019-02-23 03:16 PM

History

#1 Updated by Giovanni Manghi about 3 years ago

see attached screenshot: maybe the missing field is the reason for what you observe?

#2 Updated by Luca Lanteri about 3 years ago

no, I presume.
I've just retried giacitura.gpkg package data and I haven't got missing field.
I've also tried with QGIS 2.99 and I have the same behaviour.

#3 Updated by Giovanni Manghi about 3 years ago

  • Affected QGIS version changed from 2.18.10 to 2.18.11
  • Status changed from Feedback to Open

#4 Updated by Luca Lanteri over 2 years ago

The problem is still open on 3.0

#5 Updated by Giovanni Manghi over 2 years ago

  • Affected QGIS version changed from 2.18.11 to 3.0.0

#6 Updated by Alberto Grava over 1 year ago

I've tried on ubuntu 18.04 (with qgis 3.4.4) using giacitura.gpkg and it works correctly (see the screenshot).

#7 Updated by Alberto Grava over 1 year ago

  • Status changed from Open to Feedback

#8 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Closing of lack of feedback.

Also available in: Atom PDF