Bug report #16908

Certain Plugins crash the processing tool 2.18.10

Added by Tyler Veinot almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:C++ plugins/Globe
Affected QGIS version:2.18.10 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24807

Description

When I install Networks Plugin or the Profile Tool (https://github.com/crocovert/networks/ or https://github.com/etiennesky/profiletool) the processing plugin crashes with the error;
2017-07-21T08:32:52 1 Failed to load C:/OSGEO4~1/apps/qgis/plugins/globeplugin.dll (Reason: Cannot load library C:/OSGEO4~1/apps/qgis/plugins/globeplugin.dll: The specified module could not be found.)

When I install the Profile Tool Processing, QField Sync, and qgis2web are unable to load.

I have had all these tools working in 2.18.10 the only thing I changed recently is installing Q Server LTR using the OSGeo4W installer and postgresql. The Q Server is now uninstalled. I tried reinstalling QGIS as well as complete removal and reinstall. deleted the .qgis file and reinstalled the plugins but I still get the same behavior with those 2 plugins. I copied the python window messages into txt files attached below; one with the networks plugin the other with the profile tool. I really enjoyed these tools and would like to get them back if possible. I also posted this behavior on the tools issue trackers because I am not sure if it is something with the tools or something in QGIS or something I did to my own system.

Thanks for the help.

QGIS_Python_Message_Panel_Readout.txt Magnifier - Copy and paste of the errors from the python conole for Networks (12.6 KB) Tyler Veinot, 2017-07-21 01:43 PM

QGIS_Python_Message_Panel_Readout_2.txt Magnifier - Copy and paste of the errors from the python conole for Profile Tool (16.7 KB) Tyler Veinot, 2017-07-21 01:47 PM

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Assignee deleted (Victor Olaya)
  • Status changed from Open to Feedback

Are those plugins Processing ones, or normal ones?

You can start by disabling the "globe" core plugin in the plugin manager.

You should also remember that if a 3rd party plugin does not work as expected or causes issues in QGIS then you should file a ticket in the plugin bug tracker, not here.

It seems also that you may have a unclean environment, please try clarify/clean then report back.

#2 Updated by Giovanni Manghi almost 3 years ago

  • Category changed from Processing/Core to C++ plugins/Globe

also the error message in the descriotion has nothing to do with Processing. Could you clarify and add steps how replicate the issue?

#3 Updated by Tyler Veinot almost 3 years ago

They are normal plugins, as for the environment I also have ArcGIS with its own python versions which has caused issues in the past. I did put tickets with the 3rd party plugins as well, IZ wasn't sure where the error was and I have been working on this for a few days now.
So I cleaned my environment some and also found my GRASS and SAGA tools were all disabled, I again uninstalled everything and this time went into my environment variables and removed all OSGeo and QGIS referenced paths. Reinstalled everything and now I have my GRASS and SAGA back. I also installed the profile tool and didn't get any errors. I am confident at this point the issue is something solely my doing.
Sorry to have bothered you, you can close/delete this issue.
Thanks for the help, you did guide me to where the issue was.
Tyler

#4 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Tyler Veinot wrote:

They are normal plugins, as for the environment I also have ArcGIS with its own python versions which has caused issues in the past. I did put tickets with the 3rd party plugins as well, IZ wasn't sure where the error was and I have been working on this for a few days now.
So I cleaned my environment some and also found my GRASS and SAGA tools were all disabled, I again uninstalled everything and this time went into my environment variables and removed all OSGeo and QGIS referenced paths. Reinstalled everything and now I have my GRASS and SAGA back. I also installed the profile tool and didn't get any errors. I am confident at this point the issue is something solely my doing.
Sorry to have bothered you, you can close/delete this issue.
Thanks for the help, you did guide me to where the issue was.
Tyler

no problem.

Also available in: Atom PDF