Bug report #16907

QGIS LTR frequently crashes with a certain WMS layer

Added by Daniela Fasler about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:2.18.4 Regression?:No
Operating System:Windows 32 bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:24806

Description

I'm working with QGIS cloud 2.18.4. When I'm adding a WMS layer, QGIS frequently crashes or at least can't really work because it's so slow. In the legend window normally the WMS layer doesn't appear with it's name (only check-box). When adding more than one layer, QGIS always crashes. Thanks!

qgis-20170721-112804-11580-16380-59c1d21.zip - minidump after the crash (3.96 MB) Daniela Fasler, 2017-07-21 01:52 PM

Recording #1.mp4 (3.01 MB) Giovanni Manghi, 2017-07-21 03:12 PM

Aufnahme #1.mp4 - screencast (2.6 MB) Daniela Fasler, 2017-07-24 08:42 AM

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback
  • Priority changed from Normal to High

Please post the WMS service URL and also upgrade to the latest QGIS version available, 2.18.10.

#2 Updated by Daniela Fasler about 3 years ago

WMS URL:
http://geoshop.lu.ch/SWMS?REQUEST=GetCapabilities&SERVICE=WMS?VERSION=1.1.1
you'll need user/password

Can't update to the latest version at the moment, because it's a company installation.

#3 Updated by Giovanni Manghi about 3 years ago

Daniela Fasler wrote:

WMS URL:
http://geoshop.lu.ch/SWMS?REQUEST=GetCapabilities&SERVICE=WMS?VERSION=1.1.1
you'll need user/password

Can't update to the latest version at the moment, because it's a company installation.

can you provide us with the credentials? it can be even privately if necessary.

#4 Updated by Daniela Fasler about 3 years ago

user: xxx
pw: xxx

#5 Updated by Giovanni Manghi about 3 years ago

Daniela Fasler wrote:

user: xxx
pw: xxx

see attached screencast, no issues whatsoever here, also is fast. The layers do not show a legend because likely the server is not configured (or well configured) to create a legend for WMS layers.

#6 Updated by Daniela Fasler about 3 years ago

very strange... it has also been tested by sourcepole (Pirmin Kalberer) and there it also workes fine, but in our company, it doesn't... That's why Pirmin Kalberer recommended to post the issue here...

#7 Updated by Giovanni Manghi about 3 years ago

Daniela Fasler wrote:

very strange... it has also been tested by sourcepole (Pirmin Kalberer) and there it also workes fine, but in our company, it doesn't... That's why Pirmin Kalberer recommended to post the issue here...

you likely must look at this as a local issue: try disbaling 3rd aprty plugins, clean QGIS cache, monitor RAM consumption (as you use Windows 32bit...), etc.

If you can try remove (after a backup) the .qgis2 folder.

#8 Updated by Daniela Fasler about 3 years ago

I tried all these things, but no success.
I can load the whole WMS, it workes (also quite fast), but when I disable the WMS layer in the layer window or delete it, QGIS crashes. When I load only one layer of the WMS, it also workes, until I want to disable the layer or load another layer too.
RAM consumption is ok.

#9 Updated by Giovanni Manghi about 3 years ago

Daniela Fasler wrote:

I tried all these things, but no success.
I can load the whole WMS, it workes (also quite fast), but when I disable the WMS layer in the layer window or delete it, QGIS crashes. When I load only one layer of the WMS, it also workes, until I want to disable the layer or load another layer too.
RAM consumption is ok.

tried hard here as above, and no problems.

#10 Updated by Daniela Fasler about 3 years ago

thanks for testing...
see the screencast how it works on my machine.

#11 Updated by Giovanni Manghi about 3 years ago

Daniela Fasler wrote:

thanks for testing...
see the screencast how it works on my machine.

please try on a different machine, possibly with a QGIS 64 bit clean installation.

#12 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF