Bug report #16881

Connection to ODBC database (MS Access *.accdb)

Added by Juan Berrio almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Data Provider
Affected QGIS version:2.14.16 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:24780

Description

Problem when trying to connect to a *.accdb database via ODBC. QGIS gets frozen instead of connecting or providing an error message.

Also asked to the public in
https://gis.stackexchange.com/questions/247853/connecting-qgis-to-odbc-database-ms-access-accdb

Testing environment

Windows 7 64bit
MS Access 2016 32bit
ODBC drivers used: MS Access Database Engine 2016 32 bit (*.mdb, *.accdb)
Using ODBC 32bit config in Windows (C:\Windows\SysWOW64\odbcad32.exe)
Using QGIS 2.14.16 32bit
In QGIS, I use:

Steps to reproduce error (frozen QGIS)

1. Create *.accdb database in MS Access 2016.

2. Create ODBC connection to the database in Windows and test it works (test any other software can read it)

3. Add vector layer > Database > Type ODBC > New

4. Type ODBC > Name (name1) > Database Name (nameA)

5. Test Connect: "connection to x was successful"

6. Press OK --> QGIS gets frozen

I can read the same ODBC database from other applications (SQLite, MapInfo), so there is no problem with the ODBC side of it. It looks like something's not right on the QGIS side.

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Priority changed from Low to High
  • Status changed from Open to Feedback

Very likely a duplicated of #8752

please read that discussion, try proposed solutions(?) and report back. Thanks!

#2 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF