Bug report #16876

Relation reference widget: records with NULL display a value

Added by Andreas Neumann over 2 years ago. Updated about 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Edit widget
Affected QGIS version:2.18.10 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:24775

Description

In 2.18.x records that have a NULL value in the database and a relation reference widget assigned with the option "Allow NULL values" active show a value (the first in the list) in the widget, when in fact the data is set to NULL in the database.

This leads to the false impression that a value was selected in the relation reference widget, which is not true.

Expected: the widget should show an "empty" value, or even better: show the NULL representation (e.g. NULL as a string).

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Crashes QGIS or corrupts data changed from No to Yes

#2 Updated by salvatore fiandaca about 1 year ago

I tried in 2.18.28 and in 3.4.4 and I do not know any problems
therefore I close issues

#3 Updated by salvatore fiandaca about 1 year ago

  • Status changed from Open to Closed

#4 Updated by Giovanni Manghi about 1 year ago

salvatore fiandaca wrote:

I tried in 2.18.28 and in 3.4.4 and I do not know any problems
therefore I close issues

before closing you should put the ticket in feedback mode, and ask the issuer to check.

If you close (for example because the issuer has confirmed the issue is gone) then you also must set the resolution, thanks.

#5 Updated by Giovanni Manghi about 1 year ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF