Bug report #16859

Qgis 2.18.5 Right click on layer, View Attribute Table does not display progress and cencel button

Added by baditaflorin - over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/PostGIS
Affected QGIS version:2.18.5 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24758

Description

Use case : I have a Postgis database with million of rows.

I want to see the structure of the database, so i do right click on the layer and click View Attribute Table

I have to wait for over 5 minutes, while Qgis is frozen, to see the iloading dialog, from were i press cancel, because i just want to see some of the rows and the head of the table

In qgis 2.8.3 this happens instantaneous, loading first 10000 rows, then the next 10000 rows.

The query executed in Qgis 2.8.3 is "FETCH FORWARD 2000 FROM qgis_1"

The query that gets executed in Qgis 2.18.5 is "FETCH FORWARD 2000 FROM qgis_1"

So the query looks the same, but in Qgis 2.8.3 the loading is almost instant, and in the latest release of Qgis it can take up to 5 minutes on a larger database before loading the first rows

Step 1 http://i.imgur.com/YxrhvVI.png

Step 2 http://i.imgur.com/6ea2jvB.png

History

#1 Updated by baditaflorin - over 3 years ago

  • Status changed from Open to Closed

Upgraded to Qgis 2.18.10 and the problem is gone

#2 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF