Bug report #16838

snapping allows to snap non displayed legend classes

Added by Regis Haubourg over 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Martin Dobias
Category:Digitising
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24737

Description

When unchecking visibility of some classes for categorized or rule based renderer, snapping is still possible even though those features are not visible on map canvas.
This is annoying for some users playing a lot with classes visibility.

Thinking of it, fixing it might not be so direct, as it will imply rebuilding the snapping cache a lot more often.
And currently, it is also possible to keep snapping on an unchecked layer if it is still checked in snapping advanced dock.

Any opinion here?

History

#1 Updated by Regis Haubourg over 3 years ago

  • Subject changed from snapping allons to snap non displayed legend classes to snapping allows to snap non displayed legend classes

#2 Updated by Martin Dobias over 3 years ago

Fixing that may not require rebuilding of snapping index - snapping classes allow use of custom filters, so one could create a filter that would skip any matches that belong to invisible features...

#3 Updated by Regis Haubourg over 3 years ago

Good news!

Do you think that could be considered as a bugfix for backporting to 2.18 ?

#4 Updated by Martin Dobias over 3 years ago

Not really, I think the amount of required changes would be larger than what can be still considered as a bug fix safe for backporting...

#5 Updated by Regis Haubourg over 2 years ago

  • Assignee set to Martin Dobias
  • Affected QGIS version changed from 2.18.10 to 3.0.0

Work will start soon on that. Thanks a lot to the funder!

#6 Updated by Luigi Pirelli over 2 years ago

I can't talk from a user point of view, but I feel that snapping should't be related with the fact that the layer is rendered or not (you may thing to snapToGrid, where grid is not a layer and nor is rendered).
If, from the usability point of view, this is the expected behaviour, I would expect that it would be configurable.
IMHO it's not a bug, but a feature.

#8 Updated by Regis Haubourg over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also available in: Atom PDF