Bug report #16791

Saga no longer allows you to set folder

Added by Lennert De Feyter over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/SAGA
Affected QGIS version:2.18.10 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24690

Description

Since 2.18.10-1 I can no longer get saga algorithms to run from QGIS. They no longer appear in the processing toolbar.

I am assuming this is due to the fact that I can no longer set the saga folder as seen in the screenshot.

Kind regards

saga_folder.png (44.1 KB) Lennert De Feyter, 2017-07-05 01:42 AM

History

#1 Updated by Lennert De Feyter over 3 years ago

I have tried to remove my configuration folders and did a complete reinstall.

#2 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Open to Feedback

This is by design. Since 2.18.10 we started to only support SAGA LTR, that on standalone Windows installer is shipped by default. If you use the psgeo4w installer be sure to have installed the package SAGA 2.3.2, if you have installed the old 2.1.2 this is no longer supported.

I just tested both scenarios on clean Win7 testing VM and it all works as expected.

#3 Updated by Lennert De Feyter over 3 years ago

Ah. Sorry for the useless bug report. It does indeed work if I install the ltr version rather than the normal one. It caught me by surprise that the ltr version is later than the regular version.

Again, my apologies.

#4 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Lennert De Feyter wrote:

Ah. Sorry for the useless bug report. It does indeed work if I install the ltr version rather than the normal one. It caught me by surprise that the ltr version is later than the regular version.

Again, my apologies.

no problem mate, good to know it works.

Also available in: Atom PDF