Bug report #16790

QGIS fails to start on Ubuntu 16.10

Added by Chris Barrington-Leigh about 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.14.5 Regression?:No
Operating System:Ubuntu 16.10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24689

Description

On trying to launch QGIS (even after deleting/resetting my .qgis2 folder), I get the following (and no QGIS window):

$ qgis
Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_CA]
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_CA]
Warning: QCss::Parser - Failed to load file "/style.qss"
Warning: QMetaObject::connectSlotsByName: No matching signal for on_wvDetails_linkClicked(QUrl)
Warning: QVariantMap DBusMenuExporterDBus::getProperties(int, const QStringList&) const: Condition failed: action
Warning: QVariantMap DBusMenuExporterDBus::getProperties(int, const QStringList&) const: Condition failed: action
QH6248 qh_lib_check: Incorrect qhull library called. Caller uses reentrant Qhull while library is non-reentrant
QH6249 qh_lib_check: Incorrect qhull library called. Size of qhT for caller is 8184, but for library is 2896.
QH6255 qh_lib_check: Cannot continue. Library 'qhull 7.2.0 (2015.2 2016/01/18)' uses a dynamic qhT via qh_QHpointer (e.g., qhull_p.so)

History

#1 Updated by Andre Joost about 3 years ago

QGIS 2.14.5 is outdated (though in the official ubuntu repo).

Try http://qgis.org/debian/ yakkety main instead to get 2.14.16 (LTR) or 2.18.10 (stable), see https://www.qgis.org/de/site/forusers/alldownloads.html#debian-ubuntu

#2 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback

#3 Updated by Chris Barrington-Leigh about 3 years ago

Andre Joost wrote:

QGIS 2.14.5 is outdated (though in the official ubuntu repo).

Actually, that version is the latest on the 16.10 Ubuntu release, so should be fully supported
In any case, I get exactly the same outcome after updating to the "QGIS - 2.18.10 'Las Palmas'" release and dependencies.

Previously, QGIS was working for me, so something has gone wrong.

#4 Updated by Giovanni Manghi about 3 years ago

Chris Barrington-Leigh wrote:

Andre Joost wrote:

QGIS 2.14.5 is outdated (though in the official ubuntu repo).

Actually, that version is the latest on the 16.10 Ubuntu release, so should be fully supported
In any case, I get exactly the same outcome after updating to the "QGIS - 2.18.10 'Las Palmas'" release and dependencies.

Previously, QGIS was working for me, so something has gone wrong.

16.10 is not among the supported versions

http://qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu

upgrade to 17.04 and I'm sure it will be ok.

Supported distribution versions:
Distribution Version Codename Also available based on ubuntugis dependencies?
Debian 8.x jessie
testing stretch
unstable sid
Ubuntu 17.04 zesty [8]
16.04 (LTS) xenial [5] yes
14.04 (LTS) trusty yes
12.04 (LTS) precise [6] yes [7]

#5 Updated by Chris Barrington-Leigh about 3 years ago

Giovanni Manghi wrote:

16.10 is not among the supported versions

I think 16.10 was supported when I installed it! It stopped working, with the errors I reported above.

The fact that I get the same errors with 2.18.10 was only meant to be helpful for diagnosis.
I cannot update my OS.

#6 Updated by Giovanni Manghi about 3 years ago

I cannot update my OS.

then probably your best change to have a working qgis copy is to compile the code, is not really difficult on Ubuntu.

#7 Updated by Chris Barrington-Leigh about 3 years ago

Thanks Giovanni. I was really hoping that someone might be able to help by interpreting the error messages I got.

#8 Updated by Andre Joost about 3 years ago

Can you run apt-cache policy libqhull7 ?

Version 2015.2-1 should be the current release.

#9 Updated by Chris Barrington-Leigh about 3 years ago

Andre Joost wrote:

Can you run apt-cache policy libqhull7 ?

Version 2015.2-1 should be the current release.

Yes, that is the version it reports.

#10 Updated by Chris Barrington-Leigh about 3 years ago

SOLVED / workaround:
Here is what restored QGIS for me: (after reverting to the verison 2.14 of QGIS which is supported by Ubuntu 16.10):

pip install --user scipy==0.11

ie reverse a recent upgrade of a Python package I'd made.

#11 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

#12 Updated by Chris Barrington-Leigh about 3 years ago

Giovanni Manghi wrote:

upgrade to 17.04 and I'm sure it will be ok.

Incidentally, exactly the same problem occurs on Ubuntu 17.04. If I upgrade scipy, QGIS fails to launch.

#13 Updated by marisn - over 2 years ago

Chris Barrington-Leigh wrote:

SOLVED / workaround:
Here is what restored QGIS for me: (after reverting to the verison 2.14 of QGIS which is supported by Ubuntu 16.10):

pip install --user scipy==0.11

ie reverse a recent upgrade of a Python package I'd made.

This issue is caused by two incompatible components used by QGIS – gdal and scipy. After 0.11 scipy moved to "reentrant Qhull" version, but gdal seems to still use the "non-reentrant" version. As gdal is linked into QGIS, it makes QGIS linked to "non-reentrant" Qhull too. And at this moment scipy loads and is trying to use reentrant version of Qhull.

In short – although both gdal and scipy are fine on their own, mixing them together (in the current form) is a no go. Unfortunately my knowledge on shared library versioning is too low to propose a solution. The fact that both gdal and scipy come with their internal Qhull copies also does not help at all. As I can not roll back to scipy 0.11 (damn' fortran), only option for me is to disable any code importing scipy as --noplugins still loads plugins depending on scipy.

Also available in: Atom PDF