Bug report #1679

Legend types crash QGIS on floating point attributes

Added by Ricardo Silva over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:11739

Description

This happens whenever I try to apply a legend type of Graduated Symbol or Continuous Color on a polygon shapefile layer.
If the classification field contains integer values everything works fine, but if it contains floating point values Qgis crashes.

crashReport.tar.gz - Archive contains the console output from the crash and also a test vector file with 2 fields, one made up of integers and the other with floating point values (3.74 KB) Ricardo Silva, 2009-05-06 04:01 AM

History

#1 Updated by Giovanni Manghi over 11 years ago

Noticed also by me on qgis 1.0.1 on Ubuntu 8.10

No matter on how simple is the attribute table if the attribute is "real" instead of "integer" when you classify, qgis crashes.

#2 Updated by Jürgen Fischer over 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #1485.

Also available in: Atom PDF