Bug report #16762

DXF Export... does not work as in pre 2.18.9

Added by Peter Wallström over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DXF export
Affected QGIS version:2.18.9 Regression?:No
Operating System:Windows 10 and Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:24661

Description

The bug:
When I’m making an export of .shp files for use in Microstation.

Pre 2.18.9 it would make a level corresponding to the name of the file, since 2.18.9 it will clutter the levels with one layer per shape.
Meaning instead of Filename.dxf the levels comes in like 194_9_P_FA (this is one shape) and it will create lots of levels (one per shape in the .shp file)

LVL_Display_Microstation_from_Export_2.18.10.png - Level_Display_Microstation_BUG (31.7 KB) Peter Wallström, 2017-06-27 12:52 PM

DXF_Export.png - DXF_Export (33.1 KB) Peter Wallström, 2017-06-27 12:52 PM

LVL_Display_Microstation_from_Export_pre_2.18.9.png - Level_Display_Microstation_Working (25.8 KB) Peter Wallström, 2017-06-27 12:52 PM

Menu_SWE.png - Pointing out the function (20.2 KB) Peter Wallström, 2017-06-27 12:52 PM


Related issues

Related to QGIS Application - Bug report #17126: QGIS 2.18.12 dxf export generates one layer per feature Closed 2017-09-12

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? changed from Yes to No
  • Status changed from Open to Feedback

I'm not sure if the change was by design or not, so I cannot say if is a regression or not. Jurgen?

#2 Updated by Jürgen Fischer about 3 years ago

  • Assignee deleted (Jürgen Fischer)

#3 Updated by Giovanni Manghi about 3 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

probably duplicate of #17126 please reopen if necessary.

#4 Updated by Jürgen Fischer almost 3 years ago

  • Related to Bug report #17126: QGIS 2.18.12 dxf export generates one layer per feature added

Also available in: Atom PDF