Bug report #16743

Couldn't load PyQt - new installation qgis 2.18.9

Added by marjolein hermans over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.18.9 Regression?:No
Operating System:windows 7 professional Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:24642

Description

I am new to qgis. after installation I get the error below when I start qgis.
please advise how i could solve this.
thanks
-------------

Couldn't load PyQt.
Python support will be disabled.

Traceback (most recent call last):
File "", line 1, in
RuntimeError: the sip module implements API v10.0 but the PyQt4.QtCore module requires API v11.2

Python version:
2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)]

QGIS version:
2.18.9 'Las Palmas', 3a16a4e

Python path:
['C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python', u'C:/Users/mhermans/.qgis2/python', u'C:/Users/mhermans/.qgis2/python/plugins', 'C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python/plugins', 'C:\\PROGRA~1\\QGIS2~1.18\\bin\\python27.zip', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\DLLs', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\plat-win', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\lib-tk', 'C:\\PROGRA~1\\QGIS2~1.18\\bin', 'C:\\Users\\mhermans\\AppData\\Roaming\\Python\\Python27\\site-packages', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\site-packages', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\site-packages\\jinja2-2.7.2-py2.7.egg', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\site-packages\\markupsafe-0.23-py2.7-win-amd64.egg', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\site-packages\\win32', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\site-packages\\win32\\lib', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\site-packages\\Pythonwin', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\site-packages\\Shapely-1.2.18-py2.7-win-amd64.egg', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\site-packages\\xlrd-0.9.2-py2.7.egg', 'C:\\PROGRA~1\\QGIS2~1.18\\apps\\Python27\\lib\\site-packages\\xlwt-0.7.5-py2.7.egg']

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Open to Feedback

standalone installer or osgeo4w?

#2 Updated by marjolein hermans over 3 years ago

standalone installer from http://www.qgis.org/en/site/forusers/download.html (64 bit windows version)

#3 Updated by Giovanni Manghi over 3 years ago

try the osgeo4w one, follow the advanced install and see if the result it the same of it works.

#4 Updated by marjolein hermans over 3 years ago

i'll try. problem is that i am not administrator...

#5 Updated by marjolein hermans over 3 years ago

same problem with the osgeo4w one... unfortunately

Couldn't load PyQt.
Python support will be disabled.

Traceback (most recent call last):
File "", line 1, in
RuntimeError: the sip module implements API v10.0 but the PyQt4.QtCore module requires API v11.2

Python version:
2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)]

QGIS version:
2.18.9 'Las Palmas', 3a16a4e

Python path:
['C:/OSGEO4~1/apps/qgis/./python', u'C:/Users/mhermans/.qgis2/python', u'C:/Users/mhermans/.qgis2/python/plugins', 'C:/OSGEO4~1/apps/qgis/./python/plugins', 'C:\\OSGEO4~1\\bin\\python27.zip', 'C:\\OSGEO4~1\\apps\\Python27\\DLLs', 'C:\\OSGEO4~1\\apps\\Python27\\lib', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\plat-win', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\lib-tk', 'C:\\OSGEO4~1\\bin', 'C:\\Users\\mhermans\\AppData\\Roaming\\Python\\Python27\\site-packages', 'C:\\OSGEO4~1\\apps\\Python27', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\jinja2-2.7.2-py2.7.egg', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\markupsafe-0.23-py2.7-win-amd64.egg', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\win32', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\win32\\lib', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\Pythonwin', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\Shapely-1.2.18-py2.7-win-amd64.egg', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\xlrd-0.9.2-py2.7.egg', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\xlwt-0.7.5-py2.7.egg']

#6 Updated by Giovanni Manghi over 3 years ago

just did both (standalone and osgeo4w) on win7 pro, no issues at all. My test user has admin rights.

#7 Updated by marjolein hermans over 3 years ago

strange. here both times problems.
could my anaconda python installation(s) conflict with this python?

#8 Updated by Giovanni Manghi over 3 years ago

marjolein hermans wrote:

strange. here both times problems.
could my anaconda python installation(s) conflict with this python?

at it is almost for sure a local issue, this might be an explanation.

#9 Updated by Giovanni Manghi about 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closed for lack of feedback, please reopen if necessary.

Also available in: Atom PDF