Bug report #16742

Browser Panel: unable to find all the connected drives

Added by Harrissou Santanna about 3 years ago. Updated over 1 year ago.

Status:Open
Priority:Normal
Assignee:-
Category:Browser
Affected QGIS version:3.4.5 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24641

Description

The browser panel doesn't show all the drives I can connect to. Actually it fails to show a drive I pluged in as a network drive.
As you can see in the screenshot, the "SIG" folder (which is a folder on the macOS company network) doesn't appear in the browser panel.
However, I can have access to that folder if I use the classic Add vector/raster layer tool.

browser_missingdrives.PNG - SIG folder doesn't appear in the browser panel tree (47.7 KB) Harrissou Santanna, 2017-06-22 01:05 PM

History

#1 Updated by Harrissou Santanna over 2 years ago

I think that if we want the browser panel become the first place to add layers from (with the Data Source Manager restructuring in QGIS 3), it must be possible to show all the network and remote drivers in the tree (and not only what is accessible locally).
For what I can see, it's the only dialog in QGIS where only local drivers are accessible.

#2 Updated by Jeroen Hovens over 1 year ago

In both qgis 2.18 and qgis 3.4 running on Windows10, I use this workaround.
Right-click on the Favourites item in the brower panel and then it says : add folder. This open a windows browser panel where I have access to all the netwerk folders and I can get add them to the browser panel as a Favourite.

#3 Updated by Giovanni Manghi over 1 year ago

  • Affected QGIS version changed from 2.18.9 to 3.4.5

Also available in: Atom PDF