Bug report #16703

QGIS 3 : Node tool bug on pan

Added by Arnaud Poncet-Montanges over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System:Windows 7 x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:24602

Description

Click and pan on the node tool creates a selection rectangle which makes QGIS crash.

The user should not do this, but I did it by mistake (and old habit) so it should not make qgis crash.

2017-06-12 13_27_34-qgep_pully_poc_QGIS3 - QGIS 632a2be.png - Pan (2.58 KB) Arnaud Poncet-Montanges, 2017-06-12 01:30 PM

History

#2 Updated by Giovanni Manghi over 3 years ago

  • Priority changed from Normal to High
  • Crashes QGIS or corrupts data changed from No to Yes
  • Assignee deleted (Regis Haubourg)
  • Status changed from Open to Feedback
  • Category changed from Edit widget to Digitising

just tested on the same platform on the latest master, no crash. Or maybe I have not understand how replicate so possibly attach your data and/or attach a screencast.

#3 Updated by Richard Duivenvoorde about 3 years ago

Tested here too, both on Debian Testing and Windows7 both master version.

With shp, gpkg and memory layers tested, no crashes.

When I pan (and drag the blue box you see) I just select other points...

Please add a way/data to reproduce, or else close this issue?

#4 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

Closing for lack of feedback.

#5 Updated by Arnaud Poncet-Montanges about 3 years ago

Can't reproduce.

Also available in: Atom PDF