Bug report #16686

Accessing CSW interfaces using TLS fails with SSL error for some servers

Added by Stefan Blume about 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Tom Kralidis
Category:MetaSearch Catalogue Client
Affected QGIS version:2.18.7 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24585

Description

When accessing CSW endpoints that are using TLS (https) requesting GetCapabilities fails for certain servers.
Error message:
[Errno 8] _ssl.c:504: EOF occurred in violation of protocol

Obviously this is due to certain features the remote server is supporting. Is there any way to fix this?

metasearch_csw.GIF (17.9 KB) Stefan Blume, 2017-06-08 03:49 PM

History

#1 Updated by Stefan Blume over 2 years ago

Ok, found this is an issue due to the bundled Python 2.7.5 which is not supporting TLS 1.2.
If I do replace Python with a more current version (2.7.14) the problem disappears.

#2 Updated by Stefan Blume over 2 years ago

  • Status changed from Open to Closed

#3 Updated by Giovanni Manghi over 2 years ago

Was this closed because we assume this is fixed in QGIS3 (with Python3)?

#4 Updated by Stefan Blume over 2 years ago

I closed this issue because it is not related to MetaSearch Catalogue Client, so from my point of view it can be considered to be "invalid".
Yes, I expect a solution w/ the next major and I also do not expect a fix for this on 2.x branch, so I didn't create a new issue for QGIS itself.

#5 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to invalid

Also available in: Atom PDF