Bug report #16653

Adding New WMTS Provider, Missing Options

Added by Andy Harney over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:Yes
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24553

Description

Using QGIS 2.99 master revision 5077e12 installed via OSGeo4W64.

Adding a new WMS/WMTS server, the GUI is missing options under Version.
Options are present in the latest 2.18 & 2.14 versions.
See attached images.

Additionally, the title bar looks like there is some strange character escaping.
"Create a new MS/ connection" Whereas other versions read "Create a new WMS connection"

Many Thanks.

QGIS_2_99_0_WMTS.png - QGIS master (7.47 KB) Andy Harney, 2017-06-01 04:45 PM

QGIS_2_18_9_WMTS.png - QGIS 2.18.9 (16.6 KB) Andy Harney, 2017-06-01 04:45 PM

QGIS_2_14_15_WMTS.png - QGIS 2.14.15 (13.4 KB) Andy Harney, 2017-06-01 04:45 PM

Associated revisions

Revision 11786603
Added by Jürgen Fischer over 3 years ago

new http connection: parse service less fragile (fixes #16653; followup 1ca73f4f)

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Regression? changed from No to Yes
  • Priority changed from Normal to High
  • Category changed from GUI to Web Services clients/WMS

#2 Updated by Jürgen Fischer over 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF