Bug report #16645

GeoJson Not opening correctly QGIS 2.8.6

Added by Gonzalo Quiroga about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Vectors
Affected QGIS version:2.8.6 Regression?:No
Operating System:Kubuntu 16.04 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:24545

Description

When I try to open a GeoJson file it shows a completely wrong shape. If I open the same vector but in shapefile format (it is displayed correctly), then I create a new GeoJson file, the new GeoJason is shown correctly and if then I try again to open the first GeoJson file it is also show correctly. When I close and reopen QGIS the error persists.

This is happening as a new thing, weeks before I had no problems, I also tried to uninstall and reinstall al QGIS but the error persists.

I am runing Kubuntu:
LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description: Ubuntu 16.04.2 LTS
Release: 16.04
Codename: xenial

QGIS: 2.8.6. Detailed about in attached screenshot.

OpenGeoJason.png (83.1 KB) Gonzalo Quiroga, 2017-05-31 03:26 PM

OpenShapefile.png (105 KB) Gonzalo Quiroga, 2017-05-31 03:26 PM

OpenShapefileGeoJasonNewAndOld.png (112 KB) Gonzalo Quiroga, 2017-05-31 03:26 PM

QGISAbout.png (61.9 KB) Gonzalo Quiroga, 2017-05-31 03:26 PM

TestJson4326.geojson (647 Bytes) Gonzalo Quiroga, 2017-05-31 03:26 PM

TestJson4326New.geojson (647 Bytes) Gonzalo Quiroga, 2017-05-31 03:26 PM

TestShp4326.cpg (5 Bytes) Gonzalo Quiroga, 2017-05-31 03:26 PM

TestShp4326.dbf (76 Bytes) Gonzalo Quiroga, 2017-05-31 03:26 PM

TestShp4326.prj (143 Bytes) Gonzalo Quiroga, 2017-05-31 03:26 PM

TestShp4326.qpj (257 Bytes) Gonzalo Quiroga, 2017-05-31 03:26 PM

TestShp4326.shp (268 Bytes) Gonzalo Quiroga, 2017-05-31 03:29 PM

TestShp4326.shx (108 Bytes) Gonzalo Quiroga, 2017-05-31 03:29 PM

History

#1 Updated by Gonzalo Quiroga about 3 years ago

Forgot to say thanks! Hope it can be fixed!

Kind regards

#2 Updated by Gonzalo Quiroga about 3 years ago

Missing two files for the shapefile

#3 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback

is really 2.8 qgis you are using?

if yes please update to 2.14 or 2.18 and try again.

#4 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF